您的位置:首页 > 其它

POJ3009(dfs)

2016-07-19 10:11 281 查看
Curling 2.0

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 17672Accepted: 7262
Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.



Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.

The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.

When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).

Once thrown, the stone keeps moving to the same direction until one of the following occurs:

The stone hits a block (Fig. 2(b), (c)).

The stone stops at the square next to the block it hit.

The block disappears.

The stone gets out of the board.

The game ends in failure.

The stone reaches the goal square.

The stone stops there and the game ends in success.

You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.



Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).



Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.


the width(=w) and the height(=h) of the board
First row of the board
...
h-th row of the board


The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.


0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:


6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1



Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1
思路:见代码。


#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXN=25;
const int INF=0x3f3f3f3f;
int n,m;
int mz[MAXN][MAXN];
int sy,sx;
int dy[4]={0,1,0,-1};
int dx[4]={1,0,-1,0};
int res;
void dfs(int y,int x,int step)
{
if(step>10)
{
return ;
}
for(int i=0;i<4;i++)
{
int cury=y+dy[i];
int curx=x+dx[i];
while(0<=cury&&cury<n&&0<=curx&&curx<m&&mz[cury][curx]!=1)
{
if(mz[cury][curx]==3)
{
res=min(res,step);
return ;
}
int ny=cury+dy[i];
int nx=curx+dx[i];
if(ny<0||ny>=n||nx<0||nx>=m)//这个方向越界,换方向
{
break;
}
if(mz[ny][nx]==1)
{
mz[ny][nx]=0;
dfs(cury,curx,step+1);
mz[ny][nx]=1;
break;    //这个方向已经搜过了,换方向
}
cury=ny;//向前搜
curx=nx;
}
}
}
int main()
{
while(scanf("%d%d",&m,&n)!=EOF)
{
if(m==0&&n==0)    break;
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
scanf("%d",&mz[i][j]);
if(mz[i][j]==2)
{
sy=i;
sx=j;
}
}
}
res=INF;
dfs(sy,sx,1);
if(res!=INF)
printf("%d\n",res);
else
printf("-1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: