您的位置:首页 > 其它

POJ 1458(dp)

2016-07-19 09:52 190 查看
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab

programming contest

abcd mnp

Sample Output

4

2

0

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <queue>
#include <cmath>
#include <vector>
#include <functional>

using namespace std;
const int maxn = 1000 + 5;
char s1[maxn], s2[maxn];
int maxlen[maxn][maxn];

int main()
{
while (scanf ("%s%s", s1, s2) != EOF) {
int l1 = strlen (s1);
int l2 = strlen (s2);
memset (maxlen, 0, sizeof(maxlen));
for (int i = 1; i <= l1; i++) {
for (int j = 1; j <= l2; j++) {
if (s1[i - 1] == s2[j - 1]) {
maxlen[i][j] = maxlen[i - 1][j - 1] + 1;
} else {
maxlen[i][j] = max (maxlen[i - 1][j], maxlen[i][j - 1]);
}
}
}
printf ("%d\n", maxlen[l1][l2]);
}
return 0;
}


4000
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: