您的位置:首页 > 其它

Codeforces Round #130 (Div. 2)A Dubstep(简单字符串处理)

2016-07-19 00:23 513 查看

题目链接: 传送门

Dubstep

Time Limit: 1000MS     Memory Limit: 32768 KB

Description


Vasya works as a DJ in the best Berland nightclub, and he often uses dubstep music in his performance. Recently, he has decided to take a couple of old songs and make dubstep remixes from them.

Let's assume that a song consists of some number of words. To make the dubstep remix of this song, Vasya inserts a certain number of words "WUB" before the first word of the song (the number may be zero), after the last word (the number may be zero), and between words (at least one between any pair of neighbouring words), and then the boy glues together all the words, including "WUB", in one string and plays the song at the club.

For example, a song with words "I AM X" can transform into a dubstep remix as "WUBWUBIWUBAMWUBWUBX" and cannot transform into "WUBWUBIAMWUBX".

Recently, Petya has heard Vasya's new dubstep track, but since he isn't into modern music, he decided to find out what was the initial song that Vasya remixed. Help Petya restore the original song.


Input


The input consists of a single non-empty string, consisting only of uppercase English letters, the string's length doesn't exceed 200 characters. It is guaranteed that before Vasya remixed the song, no word contained substring "WUB" in it; Vasya didn't change the word order. It is also guaranteed that initially the song had at least one word.


Output


Print the words of the initial song that Vasya used to make a dubsteb remix. Separate the words with a space.


Sample Input

WUBWUBABCWUB
WUBWEWUBAREWUBWUBTHEWUBCHAMPIONSWUBMYWUBFRIENDWUB

Sample Output

ABC
WE ARE THE CHAMPIONS MY FRIEND

思路:


简单字符串处理,删除"WUB"输出剩下的字符。


#include<iostream>
#include<cstdio>
#include<string>
using namespace std;

int main()
{
string str,tmp;
cin >> str;
int len = str.size();
for (int i = 0;i < len;)
{
string s = str.substr(i,3);
if (s == "WUB")
{
i += 3;
}
else
{
tmp += str[i];
i++;
string s = str.substr(i,3);
if (s == "WUB")
{
tmp += ' ';
}
}
}
if (tmp != "")
cout << tmp << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: