您的位置:首页 > 其它

1025. PAT Ranking (25) PAT 甲级

2016-07-19 00:16 387 查看

Problem Description

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2

5

1234567890001 95

1234567890005 100

1234567890003 95

1234567890002 77

1234567890004 85

4

1234567890013 65

1234567890011 25

1234567890014 100

1234567890012 85

Sample Output:

9

1234567890005 1 1 1

1234567890014 1 2 1

1234567890001 3 1 2

1234567890003 3 1 2

1234567890004 5 1 4

1234567890012 5 2 2

1234567890002 7 1 5

1234567890013 8 2 3

1234567890011 9 2 4

传送门

/*
20160718
Yu
*/

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;

#define MAX_N 30010

struct Student{
char registration_number[14];
int score;
int final_rank;
int location_number;
int local_rank;
};

struct Student Stu[MAX_N];

bool cmp(struct Student a,struct Student b){
if(a.score!=b.score)    return a.score>b.score;
else return strcmp(a.registration_number,b.registration_number)<0;
}

int main(){
int T;
int N;
int StuCur=0;
int StuNum=0;
cin>>T;
for(int k=1;k<=T;k++){
cin>>N;
for(int i=0;i<N;i++){
cin>>Stu[StuNum].registration_number;
cin>>Stu[StuNum].score;
Stu[StuNum].location_number=k;
StuNum++;
}

sort(Stu+StuNum-N,Stu+StuNum,cmp);

Stu[StuNum-N].local_rank=1;

for(int j=StuNum-N+1;j<StuNum;j++){
if(Stu[j].score==Stu[j-1].score)
Stu[j].local_rank=Stu[j-1].local_rank;
else
Stu[j].local_rank=j+1-(StuNum-N);
}
/*
for(int j=StuNum-N;j<StuNum;j++){
cout<<Stu[j].registration_number<<" "<<Stu[j].local_rank<<endl;
}
*/
}

sort(Stu,Stu+StuNum,cmp);
Stu[0].final_rank=1;
for(int j=1;j<StuNum;j++){
if(Stu[j].score==Stu[j-1].score)
Stu[j].final_rank=Stu[j-1].final_rank;
else
Stu[j].final_rank=j+1;
}

cout<<StuNum<<endl;
for(int i=0;i<StuNum;i++){
cout<<Stu[i].registration_number<<" "<<
Stu[i].final_rank<<" "<<Stu[i].location_number
<<" "<<Stu[i].local_rank<<endl;
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: