您的位置:首页 > 其它

poj1458最长公共子序列问题

2016-07-18 22:12 381 查看
Language:
Default

Common Subsequence

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 47699 Accepted: 19612
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1,
i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find
the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc         abfcab
programming    contest
abcd           mnp

Sample Output
4
2
0

Source

Southeastern Europe 2003
最长公共子序列问题LCS(Longset Common Subsequence),这个问题的大致意思是给定两个字符串,s[1]……s
和t[1]……t[m],求出这两个字符串的最长公共子序列的长度。其中s[1]……s
的子序列可以为s[i1]……s[im](i1<i2<……im)
建立状态转移方程(递推式)

用dp[i][j]表示s[1]……s[i]与t[1]……t[j]的最长公共子序列的长度

则有dp[0][j]=dp[i][0]=0。

if(s[i+1]==t[j+1]) 则dp[i+1][j+1]=dp[i][j]+1;

else dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j])。

AC代码:

#include<iostream>
#include<cstring>
using namespace std;
int n,m;
int dp[1005][1005];
char s[1005],t[1005];
void solve()
{
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
if(s[i]==t[j]) dp[i+1][j+1]=dp[i][j]+1;
else dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
}
}
cout<<dp
[m]<<endl;
}
int main()
{
while(cin>>s>>t){
n=strlen(s);
m=strlen(t);
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息