您的位置:首页 > 其它

【杭电oj】1013 - Digital Roots(数论 - 九余定理,好题)

2016-07-18 20:16 477 查看
点击打开题目


Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 69396    Accepted Submission(s): 21687


Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

 

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

 

Output

For each integer in the input, output its digital root on a separate line of the output.

 

Sample Input

24
39
0

 

Sample Output

6
3

 

Source

Greater New York 2000

这道题用九余定理,看透就很简单了。

代码如下:

#include <cstdio>
#include <cstring>
int main()
{
char num[100000];
int l;
int sum;
while (~scanf ("%s",num))
{
l = strlen(num);
sum = 0;
for (int i = 0 ; i < l ; i++)
sum += num[i] - '0';
if (sum == 0)
break;
else
printf ("%d\n",(sum-1) % 9 + 1); //这个取余也很巧
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: