您的位置:首页 > 其它

hdu 1316(大整数)

2016-07-18 20:13 405 查看

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5954 Accepted Submission(s): 2331


[align=left]Problem Description[/align]
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].

[align=left]Input[/align]
The
input contains several test cases. Each test case consists of two
non-negative integer numbers a and b. Input is terminated by a = b = 0.
Otherwise, a <= b <= 10^100. The numbers a and b are given with no
superfluous leading zeros.

[align=left]Output[/align]
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.

[align=left]Sample Input[/align]

10 100
1234567890 9876543210
0 0

[align=left]Sample Output[/align]

5
4

Java大整数

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
BigInteger[] fib = new BigInteger[501];
BigInteger MAX = BigInteger.valueOf(10).pow(100);
fib[1] = BigInteger.valueOf(1);
fib[2] = BigInteger.valueOf(2);
for(int i=3;i<=500;i++){
fib[i] = fib[i-1].add(fib[i-2]);
// System.out.println(fib[i]);
}
while(sc.hasNext()){
String str1 = sc.next();
String str2 = sc.next();
if(str1.equals("0")&&str2.equals("0")) break;
BigInteger a = new BigInteger(str1);
BigInteger b = new BigInteger(str2);
int start=0,end = 0;
for(int i=1;i<=500;i++){
if(fib[i].compareTo(a)>=0) {
start = i;
break;
}
}
for(int i=1;i<=500;i++){
if(fib[i].compareTo(b)==0) {
end = i;
break;
}
if(fib[i].compareTo(b)>0){
end = i-1;
break;
}
}
//System.out.println(start+" "+end);
System.out.println(end-start+1);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: