您的位置:首页 > 其它

HDU 1335 Basically Speaking(进制转换)

2016-07-18 18:26 369 查看
[align=left]题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1335[/align]
[align=left]Problem Description[/align]
The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features:
It will have a 7-digit display.

Its buttons will include
the capital letters A through F in addition to the digits 0 through 9.

It
will support bases 2 through 16.

[align=left]Input[/align]
The input for your prototype program will consist of
one base conversion per line. There will be three numbers per line. The first
number will be the number in the base you are converting from. The second number
is the base you are converting from. The third number is the base you are
converting to. There will be one or more blanks surrounding (on either side of)
the numbers. There are several lines of input and your program should continue
to read until the end of file is reached.

[align=left]Output[/align]
The output will only be the converted number as it
would appear on the display of the calculator. The number should be right
justified in the 7-digit display. If the number is to large to appear on the
display, then print "ERROR'' (without the quotes) right justified in the
display.

[align=left]Sample Input[/align]

1111000 2 10

1111000 2 16

2102101 3 10
2102101 3 15

12312 4 2

1A 15 2
1234567 10 16
ABCD 16 15

[align=left]Sample Output[/align]
[align=left] 120 [/align]

78
1765
7CA
ERROR
11001

12D687
D071

#include<stdio.h>
#include<cstring>.
#include<iostream>
using namespace std;
char s[10];
int a,b;
int len,i,j;
long long c;
char ans[10];
int f(int j)
{
int res=1;
while(j--)
res*=a;
return res;
}
int main()
{
while(cin>>s>>a>>b)
{
len=strlen(s);
c=0;
for(i=len-1,j=0;i>=0;i--,j++)
{
if(s[i]>='0'&&s[i]<='9')
c+=(s[i]-'0')*f(j);
else
c+=(s[i]-'A'+10)*f(j);
}
//从a进制转化为十进制c
//cout<<c<<" ";//
//接下来从十进制c转换为b进制字符串ans
for(i=0;i<10;i++)
{
if(c<1)break;
ans[i]='0'+(c%b);
c/=b;
}
int len1=i;
//cout<<len1<<" ";//
if(len1>7)cout<<"  ERROR"<<endl;
else
{
for(i=1;i<=7-len1;i++)cout<<" ";
for(i=len1-1;i>=0;i--)
{
if(ans[i]>='0'&&ans[i]<='9')
cout<<ans[i];
else
printf("%c",ans[i]-'0'-10+'A');
}
cout<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: