您的位置:首页 > 其它

POJ2406 Power Strings

2016-07-18 17:36 281 查看
Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 42797 Accepted: 17855
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:给一个字符串S长度不超过10^6,求最大的n使得S由n个相同的字符串a连接而成,如:"ababab"则由n=3个"ab"连接而成,"aaaa"由n=4个"a"连接而成,"abcd"则由n=1个"abcd"连接而成。

定理:假设S的长度为len,则S存在循环子串,当且仅当,len可以被len - next[len]整除,最短循环子串为S[len - next[len]]

例子证明:
设S=q1q2q3q4q5q6q7q8,并设next[8]
= 6,此时str = S[len - next[len]] = q1q2,由字符串特征向量next的定义可知,q1q2q3q4q5q6 =
q3q4q5q6q7q8,即有q1q2=q3q4,q3q4=q5q6,q5q6=q7q8,即q1q2为循环子串,且易知为最短循环子串。由以上过程可知,若len可以被len
- next[len]整除,则S存在循环子串,否则不存在。

解法:利用KMP算法,求字符串的特征向量next,若len可以被len - next[len]整除,则最大循环次数n为len/(len - next[len]),否则为1。

注意:1.while多输入时一定要初始化 2.abbabbaa串 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char p[1000005];
int next[1000005];
void nxt(char *p)
{
int plen=strlen(p);
next[0]=-1;
int j=0,k=-1;
while(j<plen)
{
if(k==-1 || p[k]==p[j])
{
next[j+1]=k+1;
j++;k++;
}
else k=next[k];
}
}

int main()
{
while(~scanf("%s",&p) && p[0]!='.')
{
memset(next,0,sizeof next);//
nxt(p);
int len=strlen(p);
//	cout<<next[len]<<endl;
if(len%(len-next[len])==0)
printf("%d\n",len/(len-next[len]));
else printf("1\n");
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: