您的位置:首页 > 其它

poj2386 (DFS)

2016-07-18 16:23 344 查看
Lake Counting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28816 Accepted: 14437
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
Source

USACO 2004 Novembe

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
char a[110][110];//标记园子
int n,m;
void DFS(int x,int y)
{
a[x][y]='.';//将搜索过的w的位置转换成'.'
for(int dx=-1;dx<=1;dx++)//循环遍历8个方向
{
for(int dy=-1;dy<=1;dy++)
{
int nx=dx+x;
int ny=dy+y;
if(nx>=0&&nx<n&&ny>=0&&ny<m&
4000
amp;&a[nx][ny]=='W')
DFS(nx,ny);
}
}
}
int main()
{
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
{
scanf("%s",a[i]);
}
int sum=0;
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
if(a[i][j]=='W')//从W位置搜索
{
DFS(i,j);
sum++;
}
}
}
printf("%d\n",sum);
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息