您的位置:首页 > 其它

POJ 1789

2016-07-18 15:52 232 查看
这个题粗略读一遍题目,恩,没懂......

然后再看......

Kruskal算法之前都用的这个算法,但是这个题要用的是prim算法,这个算法用于稠密的图来计算最短路径

这个算法感觉用起来比Kruskal算法剪短一点没有用到之间的并查集的知识

Truck History

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24278 Accepted: 9442
Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase
letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types
were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that
the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output
The highest possible quality is 1/3.


#include <iostream>
using namespace std;
const int Max=2005;
const int inf=0xfffff;

int n,ans;
int map[Max][Max],dis[Max];

int min(int a,int b)
{
return a<b?a:b;
}

void prim()
{
int i, j, now, min_node, min_edge;
for(i = 1; i <= n; i ++)
dis[i] = inf;
now = 1;
ans = 0;
for(i = 1; i < n; i ++)
{
dis[now] = -1;
min_edge = inf;
for(j = 1; j <= n; j ++)
if(j != now && dis[j] >= 0)
{
dis[j] = min(dis[j], map[now][j]);
if(dis[j] < min_edge)
{
min_edge = dis[j];
min_node = j;
}
}
now = min_node;
ans += min_edge;
}
}

int main()
{
int i,j,k;
char truck[Max][8];
while (cin>>n&&n!=0)
{
for (i=1;i<=n;i++)
{
scanf("%s",&truck[i]);
for (j=i-1;j>=1;j--)
{
int edge=0;
for(k=0;k<7;k++)
if(truck[i][k]!=truck[j][k])
edge++;
map[i][j]=map[j][i]=edge;<span style="white-space:pre"> </span>//搜索时候的i和j j和i是一样的没有区别

}
}
prim();
printf("The highest possible quality is 1/%d.\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  最短生成树