您的位置:首页 > 其它

FOJ 2213 Common Tangents 【第六届福建省大学生程序设计竞赛】

2016-07-17 21:19 435 查看

Problem 2213 Common Tangents

Accept: 376 Submit: 1173

Time Limit: 1000 mSec Memory Limit : 32768 KB



Problem Description

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.



Now given the center and radius of two circles, your job is to find how many common tangents between them.



Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the
first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.



Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.



Sample Input

3

10 10 5 20 20 5

10 10 10 20 20 10

10 10 5 20 10 5



Sample Output

4

2

3



Source

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)

原题链接:http://acm.fzu.edu.cn/problem.php?pid=2213

题意:输入两个圆的圆心和半径,求公切线的条数。

高中数学题,公式判断!没有理解输出-1时的情况,以为是内含的时候,最后竟然是相同的时候!

不说了,英语是硬伤!!!

知识补充:



AC代码:

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int t;
double x1,y1,r1,x2,y2,r2;
cin>>t;
while(t--)
{
cin>>x1>>y1>>r1>>x2>>y2>>r2;
double d=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
int ans;
if(x1==x2&&y1==y2&&r1==r2)//相同
{
cout<<-1<<endl;
continue;
}
if(d>r1+r2)//外离
ans=4;
else if(d==r1+r2)//外切
ans=3;
else if(r1+r2>d&&d>fabs(r1-r2))//相交
ans=2;
else if(d==fabs(r1-r2))//内切
ans=1;
else if(d<fabs(r1-r2))//内含
ans=0;
cout<<ans<<endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: