您的位置:首页 > 其它

[POJ 2752]Seek the Name, Seek the Fame[kmp]

2016-07-17 17:22 417 查看
Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab

aaaaa

Sample Output

2 4 9 18

1 2 3 4 5

Source

POJ Monthly–2006.01.22,Zeyuan Zhu

给定一个字符串s,从小到大输出s中既是前缀又是后缀的子串的长度。

此题非常简单,借用KMP算法的next数组,设s的长度为n,则s串本身必定满足条件。其他满足条件的子串都有个特征,就是该子串的最后一个字符肯定与s的最后一个字符相同。这正是next数组发挥作用的时候。从n - 1位既最后一位开始回滚,若s[next[n-1]] == s[n-1],则子串s[0,1,2,…,next[n-1]]是满足条件的子串。然后判断s[next[next[n-1]]] == s[n-1]是否成立,这样一直回滚,直到next[next[…..next[n-1]]] == -1为止。把答案从大到小存下来,再从小到大输出即可。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int Next[400005];
char str[400005];
int ans[400005];
int cnt;
int len;

void getNext()
{
Next[0] = -1;
int i = 0, j = -1;
while (i < len)
{
if (j == -1 || str[i] == str[j])
{
++i;
++j;
Next[i] = j;
}
else j = Next[j];
}
}

int main()
{
while (scanf("%s", str) != EOF)
{
len = strlen(str);
getNext();
cnt = 0;
int t = Next[len - 1];
while (t != -1)
{
if (str[t] == str[len - 1]) ans[cnt++] = t + 1;
t = Next[t];
}
for (int i = cnt - 1; i >= 0; --i)
{
printf("%d ", ans[i]);
}
printf("%d\n", len);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  kmp poj