您的位置:首页 > 其它

hdu 5583 Kingdom of Black and White

2016-07-17 12:43 344 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5583
题目:
[align=left]Problem Description[/align]
In the Kingdom of Black and White (KBW), there are two kinds of frogs: black frog and white frog.

Now N
frogs are standing in a line, some of them are black, the others are white. The total strength of those frogs are calculated by dividing the line into minimum parts, each part should still be continuous, and can only contain one kind of frog. Then the strength
is the sum of the squared length for each part.

However, an old, evil witch comes, and tells the frogs that she will change the color of
at most one frog and thus the strength of those frogs might change.

The frogs wonder the maximum possible strength after the witch finishes her job.
 

[align=left]Input[/align]
First line contains an integer
T,
which indicates the number of test cases.

Every test case only contains a string with length
N,
including only 0
(representing

a black frog) and 1
(representing a white frog).


1≤T≤50.


for 60% data, 1≤N≤1000.


for 100% data, 1≤N≤105.


the string only contains 0 and 1.
 

[align=left]Output[/align]
For every test case, you should output "Case #x: y",where
x
indicates the case number and counts from 1
and y
is the answer.
 

[align=left]Sample Input[/align]

2
000011
0101

 

[align=left]Sample Output[/align]

Case #1: 26
Case #2: 10

将01串预处理成长度串。
考虑两种情况,连续一个符号和和连续多个符号。
连续一个符号考虑将讲左右两边的长度融合。
连续多个符号考虑将相邻段分一个符号到当前段。

#include <iostream>
#include<bits/stdc++.h>
#define N 110000
#define ll long long
using namespace std;

char s
;
int a
;

int main()
{
int T;
cin>>T;
for(int k=1;k<=T;k++)
{
scanf("%s",s);
int n=strlen(s);
int tp=0,m=0;
for(int i=1;i<n;i++)
{
if(s[i]!=s[i-1])
{
a[m++]=i-tp;
tp=i;
}
}
a[m++]=n-tp;
ll ans=0;
for(int i=0;i<m;i++)    ans+=(ll)a[i]*a[i];
ll mmax=ans;
for(int i=0;i<m;i++)
{
if(a[i]==1)
{
int sum=1;
ll t=1;
if(i>0) sum+=a[i-1],t+=(ll)a[i-1]*a[i-1];
if(i<m-1)   sum+=a[i+1],t+=(ll)a[i+1]*a[i+1];
mmax=max(mmax,ans+(ll)sum*sum-t);
}
else
{
if(i>0)
mmax=max(mmax,ans+(ll)(a[i]+1)*(a[i]+1)-(ll)a[i]*a[i]+(ll)(a[i-1]-1)*(a[i-1]-1)-(ll)a[i-1]*a[i-1]);
if(i<m-1)
mmax=max(mmax,ans+(ll)(a[i]+1)*(a[i]+1)-(ll)a[i]*a[i]+(ll)(a[i+1]-1)*(a[i+1]-1)-(ll)a[i+1]*a[i+1]);

}
}
printf("Case #%d: %lld\n",k,mmax);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: