您的位置:首页 > 其它

微软笔试题 《Give My Text Back》

2016-07-16 21:11 260 查看
时间限制:10000ms

单点时限:1000ms

内存限制:256MB

描述

To prepare for the English exam Little Ho collected many digital reading materials. Unfortunately the materials are messed up by a malware.

It is known that the original text contains only English letters (a-zA-Z), spaces, commas, periods and newlines, conforming to the following format:

Each sentence contains at least one word, begins with a letter and ends with a period.

In a sentence the only capitalized letter is the first letter.

In a sentence the words are separated by a single space or a comma and a space.

The sentences are separated by a single space or a single newline.

It is also known the malware changes the text in the following ways:

Changing the cases of letters.

Adding spaces between words and punctuations.

Given the messed text, can you help Little Ho restore the original text?

输入

A string containing no more than 8192 English letters (a-zA-Z), spaces, commas, periods and newlines which is the messed text.

输出

The original text.

样例输入

my Name is Little Hi.

His name IS Little ho , We are friends.

样例输出

My name is little hi.

His name is little ho, we are friends.

简单的字符串处理题。

需要注意不能输出多余的空格,比如一行末尾如果有多个空格的话,一个也不能输出。如果是单词和逗号(或句号)之间的空格都不能输出,单词和单词之间的多个空格只能输出一个。逗号(或句号)和单词之间的多个空格只能输出一个

#include <cstdio>
int main()
{
int blank = 0, end = 1;//end表示一句话是否结束
//如果已经结束,下一个字母需要大写
int pos;
char c;
while(~scanf("%c", &c)){
if (c == '.'){
putchar(c);
end = 1;
}else if (c == ' '){
blank = 1;
}else if (c == '\n'){
putchar('\n');
end = 1;
blank = 0;
}else if (c == ','){
putchar(',');
}else {
if (end){
if (c > 'Z'){
c -= 32;
}
}else{
if (c < 'a'){
c += 32;
}
}
if (blank){
putchar(' ');
}
putchar(c);
end = 0;
blank = 0;
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: