您的位置:首页 > 其它

POJ 1159 Palindrome(基础DP)

2016-07-16 18:40 513 查看
Palindrome

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5
Ab3bd

Sample Output
2

题目大意:给出一个字符串,输出插入多少字符后构成一个回文串。话说这道题和CSU校赛的F题差不多啊,只不过那道题是删除字符,而且空间给的也够大。刚开始没有注意到空间限制,开了一个dp[5005][5005]的数组,结果直接爆了内存。。。后来看到《挑战程序设计竞赛》中的相应章节,才知道原来可以利用滚动数组优化空间复杂度。。。
解题思路:动态规划问题。定义dp[i][j]为第i个字符与第j个字符之间需要插入的字符数,则可得到状态转移方程:

dp[i][j] = dp[i + 1][j - 1]                                (str[i] == str[j])

dp[i][j] = min(dp[i + 1][j],dp[i][j - 1]) + 1    (str[i] != str[j])

由于dp[i]只与dp[i]和dp[i + 1]有关,可以结合奇偶性写成如下形式:

dp[i % 2][j] = dp[(i + 1) % 2][j - 1]                                        (str[i] == str[j])

dp[i % 2][j] = min(dp[(i + 1) % 2][j],dp[i % 2][j - 1]) + 1    (str[i] != str[j])

代码如下:

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;
const int maxn = 5001;

char str[maxn];
int dp[2][maxn];

int main()
{
int n,i,j,k;
int minnum;
while(scanf("%d",&n) != EOF){
scanf("%s",str);
memset(dp,0,sizeof(dp));
for(i = n - 2;i >= 0;i--){
dp[i % 2][i] = 0;
for(j = i + 1;j < n;j++){
if(str[i] == str[j])
dp[i % 2][j] = dp[(i + 1) % 2][j - 1];
else
dp[i % 2][j] = min(dp[(i + 1) % 2][j],dp[i % 2][j - 1]) + 1;
}
}
printf("%d\n",dp[0][n - 1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ