您的位置:首页 > 其它

hdu 2222 Keywords Search(AC自动机模板)

2016-07-16 18:02 507 查看


Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 51186    Accepted Submission(s): 16482


Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.

Wiskey also wants to bring this feature to his image retrieval system.

Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.

To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

 

Input

First line will contain one integer means how many cases will follow by.

Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)

Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.

 

Output

Print how many keywords are contained in the description.

 

Sample Input

1
5
she
he
say
shr
her
yasherhs

 

Sample Output

3

题意:给n个小串,再给一个大串,问大串里有多少个小串(一个小串只能计算一次)

思路:AC自动机模板题,这里的代码可以当做模板。

关于AC自动机可以看:点击打开链接

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 10050
#define M 1000050
char s
,str[M];
struct Node
{
struct Node *next[26];///儿子
struct Node *fail;///失败指针
int num;///以当前节点为最后一个字符的字符串的个数
void init()
{
for(int i=0;i<26;i++)
next[i]=NULL;
fail=NULL;
num=0;
}
}*root;
void Insert()
{
int len=strlen(s);
Node *p=root;
for(int i=0;i<len;i++)
{
int pos=s[i]-'a';
if(p->next[pos]==NULL)
{
p->next[pos]=new Node;
p->next[pos]->init();
}
p=p->next[pos];
}
p->num++;
}
void getfail()
{
Node *p=root,*son;
queue<Node *>que;
que.push(p);
while(!que.empty())
{
Node *now=que.front();
que.pop();
for(int i=0;i<26;i++)
{
son=now->next[i];
if(son!=NULL)
{
if(now==root) now->next[i]->fail=root;
else
{
p=now->fail;
while(p)
{
if(p->next[i])
{
son->fail=p->next[i];
break;
}
p=p->fail;
}
if(!p) son->fail=root;
}
que.push(son);
}
}
}
}
void query()
{
Node *p=root,*temp;
int cnt=0,len=strlen(str);
for(int i=0;i<len;i++)
{
int pos=str[i]-'a';
while(!p->next[pos]&&p!=root) p=p->fail;
p=p->next[pos];
if(!p) p=root;
temp=p;
while(temp!=root)
{
if(temp->num>0)
{
cnt+=temp->num;
temp->num=-1;
}
else break;
temp=temp->fail;
}
}
printf("%d\n",cnt);
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n;
root=new Node;
root->init();
scanf("%d",&n);
while(n--)
{
scanf("%s",s);
Insert();
}
getfail();
scanf("%s",str);
query();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: