您的位置:首页 > 其它

LightOJ 1248 Dice (III) 概率

2016-07-16 11:51 447 查看
[b]Description[/b]

Given a dice with n sides, you have to find the expected number of times you have to throw that dice to see all its faces at least once. Assume that the dice is fair, that means when you throw the dice, the probability of occurring any face is equal.

For example, for a fair two sided coin, the result is 3. Because when you first throw the coin, you will definitely see a new face. If you throw the coin again, the chance of getting the opposite side is 0.5, and the chance of getting the same side is 0.5. So, the result is

1 + (1 + 0.5 * (1 + 0.5 * ...))

= 2 + 0.5 + 0.52 + 0.53 + ...

= 2 + 1 = 3

[b]Input[/b]

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 105).

Output

For each case, print the case number and the expected number of times you have to throw the dice to see all its faces at least once. Errors less than 10-6 will be ignored.

[b]Sample Input[/b]

5

1

2

3

6

100

[b]Sample Output[/b]

Case 1: 1

Case 2: 3

Case 3: 5.5

Case 4: 14.7

Case 5: 518.7377517640

[b] 题意:[/b]
  有一个n面的骰子,每次投出,每个面出现的概率都一样
  问你每个面都出现一次的期望
[b]题解:[/b]
  假设dp[i] 为还有i个面没有出现的期望
  那么答案是dp

  那么有
        dp[i] = (dp[i-1]*(i) + (n-i)*dp[i]) / n;
  化简一下即可

#include <cstdio>
#include <cstring>
#include <vector>
#include<iostream>
#include <algorithm>
using namespace std;
const int  N = 1e2 + 10, M = 1e5+10 , mod = 1e9 + 7, inf = 2e9;
int T,n,x;
double dp[M+20],f,p;
int main()
{
int cas = 1;
scanf("%d",&T);
while(T--) {
scanf("%d",&n);
dp[0] = 0.0;
for(int i=1;i<=n;i++) {
dp[i] = (n + dp[i-1]*i) / (double)(i);
}
printf("Case %d: %.6f\n",cas++,dp
);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: