您的位置:首页 > 其它

HDU 4771 Stealing Harry Potter's Precious(bfs+状态压缩)

2016-07-15 18:34 477 查看
Problem Description

  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows
such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left
room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious
are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access
the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from
one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.

 

Input

  There are several test cases.

  In each test cases:

  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).

  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.

  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.

  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).

  The input ends with N = 0 and M = 0

 

Output

  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.

 

Sample Input

2 3
##@
#.#
1
2 2
4 4
#@##
....
####
....
2
2 1
2 4
0 0

 

Sample Output

-1
5

 

Source

2013 Asia Hangzhou Regional Contest

 
给出一个图,‘@’是起点,‘#’不能走,‘.’可以走
另外给出k个点的坐标,k<= 4
求从起点出发,走完k个点的最少步数
bfs搜索,但是状态保存需要压缩
vis[i][j][s]表示走到(i,j)点时的状态为s,其中s记录了访问了k个点中的哪些点
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<set>
#include<stack>
#include<cmath>
#include<map>
#include<stdlib.h>
#include<cctype>
#define mem(a,x) memset(a,x,sizeof(a))
#define esp 1e-8
using namespace std;
typedef long long ll;
const int dx[] = {-1,1,0,0};
const int dy[] = {0,0,-1,1};
const int inf = 1<<29;
const int N = 100;
struct Node
{
int x,y,t;
int s[4];//保存状态=-=没有用二进制数
}h;
bool vis[N+5][N+5][1<<5];
pair<int,int>p[4];
int n,m,k;
char mp[N+5][N+5];
#define fs first
#define sc second
bool ok(Node node)
{
for (int i = 0;i < k;++i)
{
if (node.s[i] == 0) return 0;
}
return 1;
}
Node turn(Node u)//更新状态
{
for (int i = 0;i < k;++i)
{
if (p[i].fs == u.x&&p[i].sc == u.y) u.s[i] = 1;
}
return u;
}
int to(Node u)//转十进制
{
int t = 0;
for (int i = 0;i < k;++i)
{
t += u.s[i]*(1<<i);
}
return t;
}
int bfs()
{
mem(vis,0);
h.t = 0;mem(h.s,0);
queue<Node>q;
while (!q.empty()) q.pop();
q.push(h);vis[h.x][h.y][0] = 1;
while (!q.empty())
{
h = q.front();q.pop();
if (ok(h)) return h.t;
for (int i = 0;i < 4;++i)
{
Node nx = h;
nx.x+=dx[i],nx.y+=dy[i],nx.t++;
if (nx.x>=0&&nx.y>=0&&nx.x<n&&nx.y<m)
{
if (mp[nx.x][nx.y] == '#') continue;
nx = turn(nx);
int t = to(nx);
if (vis[nx.x][nx.y][t]) continue;
if (ok(nx)) return nx.t;
q.push(nx);
vis[nx.x][nx.y][t] = 1;
}
}
}
return -1;
}
int main()
{
while (scanf("%d %d",&n,&m)==2&&(n||m))
{
getchar();
for (int i = 0;i < n;++i)
{
scanf("%s",mp[i]);
for (int j = 0;j < m;++j)
{
if (mp[i][j] == '@')
{
h.x = i,h.y = j;
}
}
}scanf("%d",&k);
for (int i = 0;i < k;++i)
{
scanf("%d %d",&p[i].fs,&p[i].sc);
p[i].fs--,p[i].sc--;
}
printf("%d\n",bfs());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  状态压缩 bfs 杭电