您的位置:首页 > 其它

ACM--是否大于168--HDOJ 1037--Keep on Truckin'--水

2016-07-15 17:03 423 查看
HDOJ题目地址:传送门


Keep on Truckin'

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12655 Accepted Submission(s): 8677

Problem Description

Boudreaux and Thibodeaux are on the road again . . .

"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"

"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"

"We're not going to make it, I say!"

So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?

Input

Input to this problem will consist of a single data set. The data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.

Output

There will be exactly one line of output. This line will be:

NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

CRASH X

otherwise, where X is the height of the first underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler).

The height of the 18-wheeler is 168 inches.

Sample Input

180 160 170


Sample Output

CRASH 160


题意:输入三个数,如果三个数中有比168小的就输出CRASH %d,如果没有则输出NO CRASH

#include<stdio.h>
#include<iostream>
#include<memory.h>
using namespace std;
int res[1000000];
int main(){
int x,y,z;
while(scanf("%d%d%d",&x,&y,&z)!=EOF){
int result=400;
if(x<168){
result=x;
}
if(y<168){
if(result>y)
result=y;
}
if(z<168){
if(result>z)
result=z;
}
if(x>=168&&y>=168&&z>=168){
printf("NO CRASH\n");
}else{
printf("CRASH %d\n",result);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: