您的位置:首页 > 编程语言 > C语言/C++

1065. A+B and C (64bit) (20)

2016-07-14 22:04 351 查看
Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

 

#include <stdio.h>

int main()
{
int T,flag;
int i;
long long A,B,C,D;
scanf("%d",&T);
for(i=0;i<T;i++)
{
scanf("%lld%lld%lld",&A,&B,&C);
D = A + B;
if( A > 0 && B > 0 && D <= 0)
{
flag = 1;
}
else if(A < 0 && B < 0 && D >= 0)
{
flag = 0;
}
else if(D > C)
{
flag = 1;
}
else
{
flag = 0;
}
if(flag)
{
printf("Case #%d: true\n",i+1);
}
else
{
printf("Case #%d: false\n",i+1);
}

}
return 0;
}


 

 

 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息