您的位置:首页 > 其它

poj 3107(树形dp)

2016-07-14 17:00 351 查看
Godfather

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5860 Accepted: 2052
Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the
data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented
by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected
component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the
gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input
6
1 2
2 3
2 5
3 4
3 6

Sample Output
2 3

  //删除一个节点后将树分成多个部分 问删除那个节点可以将剩余部分的大小为最小
  //dfs dp[i]为当前以i节点为根的子树节点的大小 父亲部分为n-dp[i]
  //这题卡vector 必须用邻接表。。。
#include <vector>
#include <cstring>
#include <iostream>
#include <cstdio>
using namespace std;
const int inf=(1<<30);
const int N=5e4+5;

int f
,d
,n,Max,pre
;

struct Node
{
int v,next;
}G[N*2];

void add(int u,int v,int index)
{
G[index].v=v;
G[index].next=pre[u];
pre[u]=index;
}

int MAX(int a,int b){return a>b?a:b;}
int MIN(int a,int b){return a>b?b:a;}

void dfs(int v,int p)
{
int tol=1,ma=0;
for(int i=pre[v];i!=-1;i=G[i].next)
{
int u=G[i].v;
if(u==p) continue;
dfs(u,v);
tol+=d[u];
ma=MAX(d[u],ma); //维护孩子部分最大的
}
d[v]=tol;
f[v]=MAX(n-tol,ma);
Max=MIN(f[v],Max);
}

int main()
{
while(~scanf("%d",&n))
{
memset(f,0,sizeof(f));
memset(d,0,sizeof(d));
memset(pre,-1,sizeof(pre));
for(int i=1;i<n;i++)
{
int u,v;
scanf("%d%d",&u,&v);
add(u,v,2*i-1);
add(v,u,2*i);
}
Max=inf;
dfs(1,-1);
// for(int i=1;i<=n;i++)
// printf("%d ",f[i]);
int flag=0;
for(int i=1;i<=n;i++)
{
if(f[i]==Max&&!flag)
{
flag=1;
printf("%d",i);
}
else if(f[i]==Max)
printf(" %d",i);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: