您的位置:首页 > 其它

hdu 1856 More is better

2016-07-14 12:40 351 查看
More is better

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 23039 Accepted Submission(s): 8350

Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input

4

1 2

3 4

5 6

1 6

4

1 2

3 4

5 6

7 8

Sample Output

4

2

题目大意:

给你一些树:求节点最多的那棵树的节点数量。

思路:开一个boy数组,记录每棵树的节点数量,并查集Union的时候把一棵树的节点加到另一颗上面,最后遍历求最值,GG

#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN=10000005;
int F[MAXN],boy[MAXN];
int GetFather(int x)
{
return F[x]==x?x:F[x]=GetFather(F[x]);
}
void Union(int a,int b)
{
int t1=GetFather(a);
int t2=GetFather(b);
if(t1!=t2) {
F[t1]=t2;
boy[t2]+=boy[t1];
}
}

int main()
{
int n,a,b;
while(~scanf("%d",&n)){
for(int i=1;i<=MAXN;i++){
F[i]=i;
boy[i]=1;
}
while(n--){
scanf("%d%d",&a,&b);
Union(a,b);
}
int ans=1;
for(int i=1;i<=MAXN;i++){
ans=max(ans,boy[i]);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: