您的位置:首页 > 其它

poj 1011 sticks

2016-07-14 08:43 344 查看
Sticks

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 136894 Accepted: 32236

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9

5 2 1 5 2 1 5 2 1

4

1 2 3 4

0

Sample Output

6

5

【分析】

深搜+暴力剪枝

用一个bool的dfs(i,l,t)表示当前处于第i根棍子时,离拼成一个大棍子还剩l长度时,剩下棍子总长为t

我的代码WA了,如果发现错误请指正

累觉不爱

【我的改不对的WA代码】

//poj 1011
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
int a[65];
int n,tot,ans,len;
bool vis[65],flag;
bool dfs(int u,int l,int t) //离一个完整棍还剩多少长度
{
int i,j;
if(l==0)
{
t-=len;
if(t==0) return 1;
for(i=0;vis[i];i++);
vis[i]=1;
if(dfs(i+1,len-a[i],t)) return 1;
vis[i]=0;
t+=len;
}
else
fo(i,u,n)
if(i>1 && a[i]==a[i-1] && !vis[i-1])
continue;
else if(!vis[i] && l>=a[i])
{
l=l-a[i];
vis[i]=1;
if(dfs(i,l,t)) return 1;
l=l+a[i];
vis[i]=0;
if(a[i]==l) break;
}
}
bool cmp(int a,int b) {return a>b;}
int main()
{
int i,j,k,p;
while(scanf("%d",&n)==1 && n)
{
tot=0;flag=0;
M(vis);
fo(i,1,n)
{
scanf("%d",&a[i]);
tot+=a[i];
}
sort(a+1,a+n+1,cmp);
fo(len,a[1],tot)
if(tot%len==0)
if(dfs(1,len,tot))
{
flag=1;
printf("%d\n",len);
break;
}
if(!flag) printf("%d\n",tot);
}
return 0;
}


【别人家孩子的AC代码】

#include <iostream>
#include <algorithm>
using namespace std;
int sticks[65];
int used[65];
int n,len;
bool dfs(int i,int l,int t)//i为当前试取的棍子序号,l为要拼成一根完整的棍子还需要的长度,t初值为所有棍子总长度
{
if(l==0)
{
t-=len;
if(t==0)return true;
for(i=0;used[i];++i);            //剪枝1:搜索下一根大棍子的时候,找到第一个还没有使用的小棍子开始
used[i]=1;                           //由于排序过,找到的第一根肯定最长,也肯定要使用,所以从下一根开始搜索
if(dfs(i+1,len-sticks[i],t))return true;
used[i]=0;
t+=len;
}
else
{
for(int j=i;j<n;++j)
{
if(j>0&&(sticks[j]==sticks[j-1]&&!used[j-1]))  //剪枝2:前后两根长度相等时,如果前面那根没被使用,也就是由前面那根
continue;                                                //开始搜索不到正确结果,那么再从这根开始也肯定搜索不出正确结果,此剪枝威力较大
if(!used[j]&&l>=sticks[j])   //剪枝3:最简单的剪枝,要拼成一根大棍子还需要的长度L>=当前小棍子长度,才能选用
{
l-=sticks[j];
used[j]=1;
if(dfs(j,l,t))return true;

l+=sticks[j];
used[j]=0;

if(sticks[j]==l)    //剪枝4:威力巨大的剪枝,程序要运行到此处说明往下的搜索失败,若本次的小棍长度刚好填满剩下长度,但是后
break;           //面的搜索失败,则应该返回上一层
}
}
}
return false;
}
bool cmp(const int a, const int b)
{
return a>b;
}
int main()
{
while(cin>>n&&n)
{
int sum=0;
for(int i=0;i<n;++i)
{
cin>>sticks[i];
sum+=sticks[i];
used[i]=0;
}

sort(sticks,sticks+n,cmp);   //剪枝5:从大到小排序后可大大减少递归次数

bool flag=false;
for(len=sticks[0];len<=sum/2;++len)   //剪枝6:大棍长度一定是所有小棍长度之和的因数,且最小因数应该不小于小棍中最长的长度
{
if(sum%len==0)
{
if(dfs(0,len,sum))
{
flag=true;
cout<<len<<endl;
break;
}
}
}
if(!flag)
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: