您的位置:首页 > 其它

贪心 crosing river

2016-07-13 18:57 239 查看

题目:

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different
rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case
is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10


Sample Output

17




题解:

有T种情况,N个人,一条船,每次最多过两人,过河的时间是速度慢的人所需的时间,求所有人过河的最短时间。

将所有人过河所需的时间由小到大排序,依次由速度最快的两个人运送最慢的两个人过河。

有两种情况:1.T1+T2*2+Tn=T

2.2*T1+Tn-1+Tn=T

取最小值,当剩三个人的时候,写一个特判。

犯了一个比较弱智的问题,开数组的时候写进了循环里面,WA了好几次。

代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
int T ;
int a[1005];
scanf("%d",&T);
while(T--)
{
int n,i;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
int k=n-1;
int sum=0;
while(k>=0)
{
if(k>=3)
{
int t1 = a[0] + 2*a[1] + a[k];
int t2 = 2*a[0] + a[k] + a[k-1];
sum+=min(t1,t2);
}
else if(k==2)
{
sum+=a[1]+a[2];
}
else
{
sum+=a[k];
}
k-=2;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: