您的位置:首页 > 其它

POJ 3279 Fliptile (状压DP)

2016-07-13 14:23 267 查看
Fliptile

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7215 Accepted: 2726
Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles,
each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather
large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the
output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 

Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source
USACO 2007 Open Silver

题意:翻格子,相应的十字跟着翻转。
采用^异或运算进行判断。

import java.util.Arrays;
import java.util.Scanner;

public class A {
//Fliptile
static int[][] a =  new int[20][20];
static int[][] f =  new int[20][20];
static int[][] fi =  new int[20][20];
static int count = Integer.MAX_VALUE/2;
public static void main(String[] args) {
// TODO Auto-generated method stub
int m,n;
Scanner in = new Scanner(System.in);
m=in.nextInt();
n=in.nextInt();
for(int i=1;i<=m;i++){
for(int j=1;j<=n;j++){
a[i][j]=in.nextInt();
}
}
for(int j=0;j<=m;j++){
Arrays.fill(fi[j],0);
}
for(int i=0;i<Math.pow(2,n);i++){
//			System.out.println(Integer.toBinaryString(i));
int time = 0;
for(int j=0;j<=m;j++){
Arrays.fill(f[j],0);
}
for(int j=1;j<=n;j++){
f[1][j]=(i>>(j-1))&1;
if(f[1][j]==1)time++;
}
for(int k=2;k<=m;k++){
for(int j=1;j<=n;j++){
f[k][j]=f[k-1][j]^a[k-1][j];
if(j-1>0)f[k][j]=f[k][j]^f[k-1][j-1];					if(j+1<=n)f[k][j]=f[k][j]^f[k-1][j+1];					if(k-2>0)f[k][j]=f[k][j]^f[k-2][j];
if(f[k][j]==1)
time++;
}
}
boolean ok = true;
for(int j=1;j<=n;j++){
int x = f[m][j]^a[m][j];
if(m>1)x=x^f[m-1][j];
if(j>1)x=x^f[m][j-1];
if(j<n)x=x^f[m][j+1];
if(x==1){
ok=false;
break;
}
}
if(ok){
//				System.out.println(time);

if(time==count){
boolean gx = false;
for(int k=1;k<=m;k++){
for(int j=1;j<=n;j++){
if(fi[k][j]>f[k][j]){
gx=true;
break;
}else if(fi[k][j]<f[k][j]){
gx=false;
break;
}
}
}

if(gx){
for(int k=1;k<=m;k++){
for(int j=1;j<=n;j++){
fi[k][j]=f[k][j];
}
}
}
}
if(time<count){
count = time;
for(int k=1;k<=m;k++){
for(int j=1;j<=n;j++){
fi[k][j]=f[k][j];
}
}
}

}

}
if(count== Integer.MAX_VALUE/2)System.out.println("IMPOSSIBLE");
else{
for(int k=1;k<=m;k++){
System.out.print(fi[k][1]);
for(int j=2;j<=n;j++){
System.out.print(" "+fi[k][j]);
}
System.out.println();
}
}

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM