您的位置:首页 > 产品设计 > UI/UE

Longest Ordered Subsequence-POJ2533 <O(nlog(n))算法>

2016-07-12 18:20 441 查看

Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 45282 Accepted: 20075

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7

1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

分析:

求最长递增子序列。

O(nlogn):从第二个数开始处理,如果当前数大于前面的最大的数则将当前数加在后面,若果当前数比前面最大数小,则在前面的数中找到大于当前数的最小数,然后用当前数替换。这样可以使前面的数的“潜力”最大。处理完所有数即可。

处理n个数时间为O(n),每次要查找前面的大于当前数的最小数。由于前面的数已经是有序的了,所以可以用二分查找O(logn)。所以总时间为O(nlogn).

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int L[1010];
int b[1010];

int upper_bound_(int a[],int s,int e,int key)
{
if(key>a[e])
return e+1;
int m;
while(s<e)
{
m=s+(e-s)/2;
if(a[m]<key)
s=m+1;
else if(a[m]>key)
e=m;
else
return m;
}
return s;
}

int main()
{
int n,t;
while(scanf("%d",&n)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%d",&L[i]);
int ans=1;
b[0]=L[0];
for(int i=1;i<n;i++)
{
t=upper_bound_(b,0,ans-1,L[i]);
if(t>ans-1)
ans++;
b[t]=L[i];
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: