您的位置:首页 > 其它

hdu 1051 Wooden Sticks

2016-07-12 11:49 381 查看


Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17720    Accepted Submission(s): 7264


Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case,
and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

 

Output

The output should contain the minimum setup time in minutes, one per line.

 

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

 

Sample Output

2
1
3

 

快排的CMP 写错一个符号,,,, 样例都没错,自己也没发现,改了好久。

长度第一优先级,重量第二优先级。排序,就过了。

代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node{
int x,y,flag;
}s[5005];
bool cmp(node a,node b){
if(a.x==b.x) return a.y<b.y;
return a.x<b.x;
}
int main(){
int T,n;
scanf("%d",&T);
while(T--){
for(int i=0;i<5005;i++) s[i].flag=0;
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%d%d",&s[i].x,&s[i].y);
}sort(s,s+n,cmp);int count=0;
for(int i=0;i<n;i++){
int k;
if(s[i].flag==1) continue;//printf("%d %d %d\n",s[i].x,s[i].y,count);
s[i].flag=1;
count++;k=i;
for(int j=i;j<n;j++){
if(s[j].flag==0&&s[j].x>=s[k].x&&s[j].y>=s[k].y){
s[j].flag=1;
k=j;
}
}
}
printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: