您的位置:首页 > 其它

hihocoder太阁面经算法竞赛8-Dice Possibility

2016-07-11 23:55 302 查看
hihocoder太阁面经算法竞赛8-Dice Possibility。 

题目: 


描述

What is possibility of rolling N dice and the sum of the numbers equals to M?


输入

Two integers N and M. (1 ≤ N ≤ 100, 1 ≤ M ≤ 600)


输出

Output the possibility in percentage with 2 decimal places.

样例输入
2 10


样例输出
8.33


这道题比较简单,使用模拟的方法,即可解决。 

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
const int maxn = 605;
const int maxm = 102;
const double min_val = 1e-9;

int n,m;
double mp[maxm][maxn];

int main(){
freopen("in.txt", "r", stdin);

int i,j,k, cnt;
while(scanf("%d %d", &n, &m) != EOF){
if(n > m || 6*n < m){
printf("%.2f\n", 0.00);
continue;
}
memset(mp, 0, sizeof(mp));
mp[0][0] = 1.0; cnt = 0;
for(i=1; i<=n; i++){
for(j=cnt; j<=6*cnt; j++){
for(k=1; k<=6; k++){
mp[i][j+k] += mp[i-1][j]*(1.0/6.0);
}
}
cnt++;
}
printf("%.2f\n", mp
[m]*100);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法