您的位置:首页 > 其它

HDU 1710 Binary Tree Traversals

2016-07-11 15:16 387 查看
Problem Description

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed
or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.



 

Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume
they are always correspond to a exclusive binary tree.

 

Output

For each test case print a single line specifying the corresponding postorder sequence.

 

Sample Input

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

 

Sample Output

7 4 2 8 9 5 6 3 1

 

Source

HDU 2007-Spring Programming Contest

题目大意:已知树的前序和中序, 求后序遍历数列;

题解:#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
#define fr(x) freopen(x,"r",stdin)
#define fw(x) freopen(x,"w",stdout)
int qian[2000],zhong[2000] , flag;
void buildtree(int a,int b,int n,int k )
{
if(n==1)
{
printf("%d ",qian[a]);
return ;
}
else if(n<=0) return ;
int flag = 0 ;
while(qian[a]!=zhong[b+flag]) flag++ ;
buildtree(a+1,b,flag,0);
buildtree(a+flag+1,b+flag+1,n-flag-1,0);
if(k==1)
printf("%d",qian[a]);
else
printf("%d ",qian[a]);
}
int main()
{
int n;
//*fw("out.txt");
while(cin>>n)
{
for(int i=1;i<=n;i++) scanf("%d",&qian[i]);
for(int i=1;i<=n;i++) scanf("%d",&zhong[i]);
buildtree(1,1,n,1);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: