您的位置:首页 > 其它

HDU 1051 Wooden Sticks (贪心入门)

2016-07-11 10:50 405 查看
Wooden Sticks
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be
2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case,
and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1


Sample Output

2
1
3


   

     分析:长度不同按长度从小到大排,长度相同,按重量从小到大排。

AC代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct sgm
{
int l,w;
} a[5005];
bool cmp(sgm A,sgm B)
{
if(A.l!=B.l)
return A.l<B.l;//按长度排
else
return A.w<B.w;//按重量排
}
int main()
{
int n,i,j,m;
scanf("%d",&n);
while(n--)
{
scanf("%d",&m);
for(i=0; i<m; i++)
scanf("%d%d",&a[i].l,&a[i].w);
sort(a,a+m,cmp);
int book[5005]={0};
int x,s=0;
for(i=0; i<m; i++)
{
if(book[i]==0)
{
x=a[i].w;
for(j=i+1; j<m; j++)
{
if(a[j].w>=x&&book[j]==0)
{
x=a[j].w;
book[j]=1;
}
}
s++;
}
}
printf("%d\n",s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: