您的位置:首页 > 其它

poj 1654 Area

2016-07-10 23:48 441 查看
Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4

5

825

6725

6244865

Sample Output

0

0

0.5

2

【分析】

利用叉积求面积

叉积:对于一个有一个顶点在坐标原点的三角形

S=abs(x1*y2-x2*y1)/2

对于这道题,求面积就是把这个多边形拆成一堆三角形来求面积和

但是不能直接取abs,因为容斥原理(怒装一笔)

随便一个反例都能举出来的。。

再次被long long 坑死

【代码】

//poj 1654 Area
#include<iostream>
#include<cstdio>
#define fo(i,j,k) for(int i=j;i<=k;i++)
using namespace std;
int lyl[10]={0,-1,0,1,-1,0,1,-1,0,1};
int czy[10]={0,-1,-1,-1,0,0,0,1,1,1};
int T,x1,y1,x2,y2;
long long ans;
string s;
int main()
{
scanf("%d",&T);
while(T--)
{
ans=0,x1=0,y1=0;
cin>>s;
if(s.size()<=2)
{
printf("0\n");
continue;
}
fo(i,0,s.size()-2)
{
x2=x1+lyl[s[i]-'0'];
y2=y1+czy[s[i]-'0'];
ans+=x1*y2-x2*y1;
x1=x2;
y1=y2;
}
if(ans<0) ans=-ans;
if(ans%2==1) printf("%lld.5\n",ans/2);
else printf("%lld\n",ans/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数论