您的位置:首页 > 其它

悼念512汶川大地震遇难同胞――老人是真饿了(贪心)

2016-07-10 16:26 471 查看
对于幸存的灾民来说,最急待解决的显然是温饱问题,救灾部队一边在组织人员全力打通交通,一边在组织采购粮食。现在假设下拨了一定数量的救灾经费要去市场采购大米(散装)。如果市场有m种大米,各种大米的单价和重量已知,请问,为了满足更多灾民的需求,最多能采购多少重量的大米呢?

Input

输入数据首先包含一个正整数C,表示有C组测试用例,每组测试用例的第一行是两个整数n和m(0<n<=1000,0<m<=1000),分别表示经费的金额和大米的种类,然后是m行数据,每行包含2个整数p和h(1<=p<=25,1<=h<=100),分别表示单价和对应大米的重量。

Output

对于每组测试数据,请输出能够购买大米的最多重量(你可以假设经费买不光所有的大米)。

每个实例的输出占一行,保留2位小数。

Sample Input

1

7 2

3 3

4 4

Sample Output

2.33

思路:根据单价升序排列,然后贪心购买即可,注意数据类型为double

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
struct node
{
double price;//单价
double weight;//重量
} num[1005];
bool cmp(node x,node y)
{
return x.price<y.price;
}
int main()
{
int C;
scanf("%d",&C);
while(C--)
{
double N;//总经费
int M;//数据组数
scanf("%lf%d",&N,&M);
for(int i=0; i<M; i++)
scanf("%lf%lf",&num[i].price,&num[i].weight);
sort(num,num+M,cmp);
double sum_weight=0.0;//总重量
for(int i=0; i<M; i++)
{
if(num[i].price*num[i].weight<N)
{
N-=num[i].price*num[i].weight;
sum_weight+=num[i].weight;
}
else
{
sum_weight+=N/num[i].price;
break;
}
}
printf("%.2lf\n",sum_weight);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: