您的位置:首页 > 其它

hdu 5086 Revenge of Segment Tree(思路)

2016-07-10 15:11 417 查看


Revenge of Segment Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1539    Accepted Submission(s): 551


Problem Description

In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the
structure is built. A similar data structure is the interval tree.

A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.

---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.

 

Input

The first line contains a single integer T, indicating the number of test cases. 

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]

1. 1 <= T <= 10

2. 1 <= N <= 447 000

3. 0 <= Ai <= 1 000 000 000

 

Output

For each test case, output the answer mod 1 000 000 007.

 

Sample Input

2
1
2
3
1 2 3

 

Sample Output

2
20
HintFor the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20.
Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded.
And one more little helpful hint, be careful about the overflow of int.

题意:求出序列所有连续区间的和

思路:我们可以枚举以a[i]区间第一个数的全部连续序列和,这样就能得到递推关系了。 以a[i]开始的区间的和会等于以a[i-1]开始的区间的和减去(n-i+1)*a[i-1]

注意和可能会炸long long!!!!!!!!要步步取模,因为都是加法和减法不会影响结果!

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
#define N 500000
#define mod 1000000007
long long a
,sum
;
long long ans,n;
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%lld",&n);
long long s=0;
for(int i=0;i<n;i++)
{
scanf("%lld",&a[i]);
if(i==0) sum[i]=a[i];
else sum[i]=sum[i-1]+a[i];
s=(s+sum[i])%mod;
}
ans=s;
for(int i=1;i<n;i++)
{
s=((s-a[i-1]*(n-i+1))%mod+mod)%mod;
ans=(ans+s)%mod;
}
printf("%lld\n",ans%mod);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: