您的位置:首页 > 其它

hdu 1051 Wooden Sticks

2016-07-09 18:10 337 查看
Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17650 Accepted Submission(s): 7229

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3

5

4 9 5 2 2 1 3 5 1 4

3

2 2 1 1 2 2

3

1 3 2 2 3 1

Sample Output

2

1

3

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=5010;
struct node
{
int l,w;
int flag;
} a[maxn];
bool cmp1(node x,node y)
{
if(x.l==y.l)
return x.w<y.w;
else
return x.w<y.w;
}
bool cmp2(node x,node y)
{
if(x.w==y.w)
return x.l<y.l;
else
return x.l<y.l;
}
int main()
{
int t,i,j,n;
cin>>t;
while(t--)
{
cin>>n;
for(i=0; i<n; i++)
{
scanf("%d%d",&a[i].l,&a[i].w);
a[i].flag=0;
}
sort(a,a+n,cmp1);
sort(a,a+n,cmp2);
int sum=0;
for(i=0; i<n; i++)//根据结构体的排序后的顺序,a[i].l依次递增,但是a[i].w
{//不是的,因此我们可以根据a[i].w来找,这也运用了贪心的
if(a[i].flag==0)//思想a[i].w依次递增,依次更新,当遇到不递增此时的标记
{ //依然为0,从新开始使用第一个木块
a[i].flag=1;
sum++;
int x=a[i].w;
for(j=i+1; j<n; j++)
{
if(a[j].flag==0&&a[j].w>=x)
{
a[j].flag=1;
x=a[j].w;
}
}
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: