您的位置:首页 > 其它

poj 1195(二维树状数组)

2016-07-09 00:30 267 查看
Mobile phones

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 18031Accepted: 8314
Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries
about the current total number of active mobile phones in any
rectangle-shaped area.

Input

The
input is read from standard input as integers and the answers to the
queries are written to standard output as integers. The input is encoded
as follows. Each input comes on a separate line, and consists of one
instruction integer and a number of parameter integers according to the
following table.



The values will always be in range, so there is no need to check
them. In particular, if A is negative, it can be assumed that it will
not reduce the square value below zero. The indexing starts at 0, e.g.
for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <=
3.

Table size: 1 * 1 <= S * S <= 1024 * 1024

Cell value V at any time: 0 <= V <= 32767

Update amount: -32768 <= A <= 32767

No of instructions in input: 3 <= U <= 60002

Maximum number of phones in the whole table: M= 2^30

Output

Your
program should not answer anything to lines with an instruction other
than 2. If the instruction is 2, then your program is expected to answer
the query by writing the answer as a single line containing a single
integer to standard output.
Sample Input

0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3

Sample Output

3
4

题意:四种操作,询问加更新。
题解:二维树状数组维护,下标从0开始。


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
using namespace std;
const int N = 1100;
int c

,n;
int lowbit(int x){
return x&(-x);
}
void update(int x,int y,int v){
for(int i=x;i<=n;i+=lowbit(i)){
for(int j=y;j<=n;j+=lowbit(j)){
c[i][j] += v;
}
}
}
int getsum(int x,int y){
int sum = 0;
for(int i=x;i>=1;i-=lowbit(i)){
for(int j=y;j>=1;j-=lowbit(j)){
sum+=c[i][j];
}
}
return sum;
}
int main()
{
int opr;
while(scanf("%d",&opr),opr!=3){
if(opr==0){
scanf("%d",&n);
memset(c,0,sizeof(c));
}else if(opr==1){
int x,y,v;
scanf("%d%d%d",&x,&y,&v);
update(x+1,y+1,v);
}else{
int l,b,r,t;
scanf("%d%d%d%d",&l,&b,&r,&t);
printf("%d\n",getsum(r+1,t+1)-getsum(l,t+1)-getsum(r+1,b)+getsum(l,b));
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: