您的位置:首页 > 其它

How Many Tables(并查集)

2016-07-08 11:44 169 查看

How Many Tables

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23308    Accepted Submission(s): 11604

[/align]

[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

 

[align=left]Sample Output[/align]

2
4

 

[align=left]Author[/align]
Ignatius.L
 

[align=left]Source[/align]
杭电ACM省赛集训队选拔赛之热身赛

 

[align=left]Recommend[/align]
Eddy   |   We have carefully selected several similar problems for you:  1272 1232 1856 1325 1233

 
#include <iostream>
#include <cstdio>
#include <set>

using namespace std;

const int maxn = 1000+100;

int high[maxn];
int par[maxn];

void init(int n)
{
for (int i=1; i<=n; i++) //啊啊啊,终于找到你,1~n过,0~n-1就WA
{
high[i] = 0;
par[i] = i;
}
}

int findr(int x)
{
if (par[x] == x)
{
return x;
}
else
{
return par[x] = findr(par[x]);
}
}

void uni(int x, int y)
{
x = findr(x);
y = findr(y);
if (x == y)
{
return ;
}
if (high[x] > high[y])
{
par[y] = x;
}
else
{
par[x] = y;
if (high[x] == high[y])
{
high[y]++;
}
}
}

void ans(int n)
{
set<int> s;
for (int i=1; i<=n; i++) //啊啊啊,终于找到你,1~n过,0~n-1就WA
{
s.insert(findr(i));
cout << findr(i) << endl;
}
cout << s.size() << endl;
}

int main()
{
int t;
int n, m;
int x, y;
scanf("%d", &t);
while( t-- )
{
scanf("%d%d", &n, &m);
init(n);
for (int i=0; i<m; i++)
{
scanf("%d%d", &x, &y);
uni(x, y);
}
ans(n);
}
return 0;
}


哎。别人都在写新的任务,我就返回来为了一道麻烦的cccc写了会简单的并查集,哎,做题做的太少啦~~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: