您的位置:首页 > 其它

POJ 2559 Largest Rectangle in a Histogram

2016-07-06 21:24 246 查看
Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3

4 1000 1000 1000 1000

0

Sample Output

8

4000

一道单调栈的模板题:

初始化栈为空,并在之后始终保持队首元素为最值

将当前元素和栈顶元素比较,若优于栈顶元素,则栈顶元素出栈 直到当前元素不优于栈顶元素,当前元素进栈

对于原数组每一个元素 ai 都执行以上的操作

#include<iostream>
#include<cstring>
#include<cstdio>
#include<stack>
using namespace std;
stack<int>stk;
int n,len[100001],h[100001];
int main()
{
while(scanf("%d",&n)==1&&n)
{
long long ans=0;
memset(len,0,sizeof(len));
for(int i=1;i<=n;i++)
scanf("%d",&h[i]);
for(int i=1;i<=n;i++)
{
while(!stk.empty()&&h[i]<h[stk.top()])
{
len[i]+=len[stk.top()];
ans=max(ans,(long long)len[i]*h[stk.top()]);
stk.pop();
}
len[i]++;
stk.push(i);
}
int l=0;
while(!stk.empty())
{
l+=len[stk.top()];
ans=max(ans,(long long)h[stk.top()]*l);
stk.pop();
}
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: