您的位置:首页 > 其它

PAT 1057. Stack

2016-07-05 15:10 197 查看
Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 10^5). Then N lines follow, each contains a command in one of the following 3 formats:

Push key

Pop

PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print “Invalid” instead.

Sample Input:

17

Pop

PeekMedian

Push 3

PeekMedian

Push 2

PeekMedian

Push 1

PeekMedian

Pop

Pop

Push 5

Push 4

PeekMedian

Pop

Pop

Pop

Pop

Sample Output:

Invalid

Invalid

3

2

2

1

2

4

4

5

3

Invalid

思路:树状数组加二分查找,用元素索引进行二分查找。

#include<cstdio>
#include<stack>
#include<cstring>
using namespace std;
const int maxn=100005;
char op[15];
int c[maxn];
int lowbit(int x){
return x&(-x);
}
int sum(int x){
int res=0;
while(x>0){
res+=c[x];
x-=lowbit(x);
}
return res;
}
void add(int x,int d){
while(x<100005){
c[x]+=d;
x+=lowbit(x);
}
}
int getmid(int size){
int index=(1+size)/2;
int left=1,right=100000,mid;
while(left<right){
mid=(left+right)/2;//索引值为一半的数是中位数
if(sum(mid)<index)
left=mid+1;
else
right=mid;
}
return left;
}
int main(){
//freopen("in.txt","r",stdin);
int T,val;
memset(c,0,sizeof(c));
scanf("%d",&T);
stack<int>s;
while(T--){
scanf("%s",op);
if(op[1]=='u'){
scanf("%d",&val);
s.push(val);
add(val,1);//更新元素索引
}
else{
if(s.empty()){
puts("Invalid");
}
else{
if(op[1]=='o'){
printf("%d\n",s.top());
add(s.top(),-1);//删除值,更新元素索引
s.pop();
}
else if(op[1]=='e'){
printf("%d\n",getmid(s.size()));
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: