您的位置:首页 > 其它

hdoj 1513 Palindrome(LCS)

2016-07-01 22:46 309 查看


Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4893    Accepted Submission(s): 1681


Problem Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

 

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

 

Sample Input

5
Ab3bd

 

Sample Output

2

 

题意:给你一个字符串,问你最少插入几个字符可以形成回文串。

解题思路:
回文串:正反读都一样。
要加最少的字符,让他成为回文串,可以将他倒置,求出最长公共子序列,这些是可以实现回文的,不需要再添加,然后用原字符串的长度减去这些公共的即可得到需要添加的。
求最大公共子序列(LCS)不优化的话dp[5005][5005],会超内存,所以要用滚动数组。

代码:
/*
Sample Input
5
Ab3bd

Sample Output
2
*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 5005;
int dp[2][maxn];
char str[maxn];
int main(void)
{
int len;
while(~scanf("%d", &len))
{
memset(dp, 0, sizeof(dp));
scanf("%s", str);
for(int i = 0; i < len; i++)
{
for(int j = 0; j < len; j++)
{
if(str[i] == str[len-j-1]) dp[(i+1)%2][j+1] = dp[i%2][j] + 1;
else dp[(i+1)%2][j+1] = max(dp[i%2][j+1], dp[(i+1)%2][j]);
}
}
printf("%d\n", len - dp[(len)%2][len]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  DP