您的位置:首页 > 其它

hdu3535 AreYouBusy (混合背包)

2016-07-01 21:55 369 查看
AreYouBusy

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3827 Accepted Submission(s): 1512

Problem Description

Happy New Term!

As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.

What’s more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as “jobs”. A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss’s advice)?

Input

There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s ( 0 < m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

Output

One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

Sample Input

3 3

2 1

2 5

3 8

2 0

1 0

2 1

3 2

4 3

2 1

1 1

3 4

2 1

2 5

3 8

2 0

1 1

2 8

3 2

4 4

2 1

1 1

1 1

1 0

2 1

5 3

2 0

1 0

2 1

2 0

2 2

1 1

2 0

3 2

2 1

2 1

1 5

2 8

3 2

3 8

4 9

5 10

Sample Output

5

13

-1

-1

**

这道题让我最无语的地方是,我TM题意理解错了!!!!

0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely

所以我以为是1的时候是01背包,2的时候是完全背包!! 还是太年轻!!!

**

其实这道题就是几个背包混一起,处理还是和普通的背包类似,只是先做一下hdu3033这道题就很简单了!

#include<bits/stdc++.h>
using namespace std;

#define si(x) scanf("%d",&(x))
typedef pair<int,int> P;
#define cls(x,y) memset((x),(y),sizeof((x)));
const int maxn=105;

typedef struct notes {
int type;
vector<P> vs;
bool operator <(struct notes aa) const {
return type<aa.type;
}
} note;
vector<notes> vec;
int n,T,m,s;

int dp[maxn][maxn];

int main() {
#ifdef tangge
freopen("3535.txt","r",stdin);
#endif
while(~scanf("%d%d",&n,&T)) {
vec.clear();
for(int i=1; i<=n; ++i) {
si(m),si(s);
note Tn;
Tn.vs.clear();
Tn.type=s;
for(int j=0; j<m; ++j) {
int u,v;
si(u),si(v);
Tn.vs.push_back(make_pair(u,v));
}
vec.push_back(Tn);
}
cls(dp,-1)
cls(dp[0],0)
for(int i=1; i<=n; ++i) {
int tnum=vec[i-1].vs.size();
if(vec[i-1].type==0) { //at least 1
for(int k=0; k<tnum; ++k) {
int tsnum=vec[i-1].vs[k].first;
for(int j=T; j>=tsnum; --j) {
if(dp[i][j-tsnum]!=-1) {
dp[i][j]=max(dp[i][j],dp[i][j-tsnum]+vec[i-1].vs[k].second);
}
if(dp[i-1][j-tsnum]!=-1) {
dp[i][j]=max(dp[i][j],dp[i-1][j-tsnum]+vec[i-1].vs[k].second);
}
}
}
} else if(vec[i-1].type==1) {
for(int l=0; l<=T; ++l)dp[i][l]=dp[i-1][l];
for(int k=0; k<tnum; ++k) {
int tsnum=vec[i-1].vs[k].first;
for(int j=T; j>=0; --j) {
if(j>=tsnum&&dp[i-1][j-tsnum]!=-1) {
dp[i][j]=max(dp[i][j],dp[i-1][j-tsnum]+vec[i-1].vs[k].second);
}
}
}
} else if(vec[i-1].type==2) {
for(int l=0; l<=T; ++l)dp[i][l]=dp[i-1][l];
for(int k=0; k<tnum; ++k) {
int tsnum=vec[i-1].vs[k].first;
for(int j=T; j>=0; --j) {
if(j>=tsnum) {
if(dp[i][j-tsnum]!=-1&&dp[i][j]<dp[i][j-tsnum]+vec[i-1].vs[k].second) {
dp[i][j]=dp[i][j-tsnum]+vec[i-1].vs[k].second;
}
}
}
}
}
}
printf("%d\n",dp
[T]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: