您的位置:首页 > 其它

杭电acm1002

2016-07-01 17:15 253 查看

[align=left]Problem Description[/align]
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it
can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.<br>Problem descriptions as follows: Given
you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?<br>
 

[align=left]Input[/align]
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. <br><br>Input contains multiple test cases. Process
to the end of file.<br>
 

[align=left]Output[/align]
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. <br>
 

[align=left]Sample Input[/align]

3
1.0 1.0
2.0 2.0
2.0 4.0

 
[align=left]Sample Output[/align]

3.41

[align=left](1)大意:[/align]
[align=left]  在一张纸上,有坐标轴,而且散列者很多点,每一点与墨水用直线连接,使所有的点最后在同一个地方连接起来。求形成这个水墨画的最短长度[/align]
[align=left](2)思路:[/align]
[align=left]
[/align]
[align=left]还是生成树问题,用kruskal算法。定义一个结构体数组,比较函数,值寻找函数备用,对树进行初始化,根据kruscle算法的规则,选取两点权值最小的边进行链接,链接的点都设置为已经访问过,然后在数组中继续寻找,直到所有的点都连起来,这包含了贪心的思想,局部最优,所有的两点都是最短的,最后连接成整体,就是总体最短。[/align]
[align=left](2)感想:[/align]
[align=left]第一次,一次提交就对了,很激动,还又试了好几遍。很简单吧,就是麻烦点,程序很长,但是思路就是一个最小生成树的kruskal算法[/align]
[align=left]
[/align]
[align=left]
[/align]
[align=left](4):[/align]
[align=left]
[/align]
#include <iostream>

#include <algorithm>

#include <cstdio>

#include <cmath>

using namespace std;

const int N=10005;

double leftt
,rightt
;

//double value
;

int father
,r
;

struct point{

  int x,y;

  double value;

}aa
4000
[10005];

int cmp(const int i,const int j){

 return aa[i].value<aa[j].value;

}

int find(int x){

  if(father[x]!=x)

   father[x]=find(father[x]);

  return father[x];

}

int main(){

  int n;

  while(scanf("%d",&n)!=EOF){

   for(int i=0;i<N;++i){

     father[i]=i;

  r[i]=i;

  aa[i].value=0.0;

   }

   

   for(int i=0;i<n;++i){

     scanf("%lf%lf",&leftt[i],&rightt[i]);

   }

   int k=0;

   for(int i=0;i<n;++i){

    for(int j=0;j<n;++j){

     if(i!=j)

     {aa[k].value=sqrt((leftt[i]-leftt[j])*(leftt[i]-leftt[j])+(rightt[i]-rightt[j])*(rightt[i]-rightt[j]));

       aa[k].x=i;

    aa[k].y=j;

    k++;

     }

    }

   }

   double sum=0;

   for(int i=0;i<k;++i){

     int e=r[i];

  int x=find(aa[e].x);

   int y=find(aa[e].y);

  if(x!=y){

   sum+=aa[e].value;

 

    father[x]=y;

  }

   }

   printf("%.2lf\n",sum);

  }

  return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: