您的位置:首页 > 其它

Fibonacci

2016-07-01 11:56 295 查看
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0

9

999999999

1000000000

-1

Sample Output

0

34

626

6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

练练手感:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<map>
#include<set>
using namespace std;
#define N 10000;
struct r{
long long int m[2][2];
}ans, tmp;

r multi(r a,r b){
r cnt;
cnt.m[0][0]=(a.m[0][0]*b.m[0][0]+a.m[0][1]*b.m[1][0])%N;
cnt.m[0][1]=(a.m[0][0]*b.m[0][1]+a.m[0][1]*b.m[1][1])%N;
cnt.m[1][0]=(a.m[1][0]*b.m[0][0]+a.m[1][1]*b.m[1][0])%N;
cnt.m[1][1]=(a.m[1][0]*b.m[0][1]+a.m[1][1]*b.m[1][1])%N;
return cnt;
}

void  Matrix_power(int n){
tmp.m[0][0]=tmp.m[0][1]=tmp.m[1][0]=1;
tmp.m[1][1]=0;
ans.m[0][0]=ans.m[1][1]=1,ans.m[1][0]=ans.m[0][1]=0;
n-=2;
while(n){
if(n&1)
ans=multi(tmp,ans);
tmp=multi(tmp,tmp);
n>>=1;
}
int s=(ans.m[0][0]+ans.m[0][1])%N;
cout<<s<<endl;
}

int main(){
int nn;
while(cin>>nn&&nn!=-1){
if(nn==0){
cout<<0<<endl;
continue;
} else if(nn==1||nn==2){
cout<<1<<endl;
continue;
}
Matrix_power(nn);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: