您的位置:首页 > 其它

HDU1518:Square

2016-06-29 12:27 351 查看

Square

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12571 Accepted Submission(s): 4008


[align=left]Problem Description[/align]
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

[align=left]Input[/align]
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

[align=left]Output[/align]
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

[align=left]Sample Input[/align]

3
4 1 1 1 1

5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

[align=left]Sample Output[/align]

yes
no
yes

思路:先排序,再dfs,详细见代码。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN=25;
int n,sum,l;
int sticks[MAXN];
int vis[MAXN];
bool dfs(int dep,int len,int start,int num)//dep:dfs深度,len:目前sticks组成的长度,start:开始深搜的位置,num:组成的边数
{
if(dep==n)
{
if(num==4)
return true;
else
return false;
}
for(int i=start;i<n;i++)
{
if(!vis[i]&&len+sticks[i]<=l)
{
vis[i]=1;
if(len+sticks[i]==l)
{
if(dfs(dep+1,0,0,num+1))//组成一个边从头开始搜
return true;
}
else
{
if(dfs(dep+1,len+sticks[i],i+1,num))//继续向前搜
return true;
}
vis[i]=0;
}
}
return false;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(vis,0,sizeof(vis));
sum=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&sticks[i]);
sum+=sticks[i];
}
if(sum%4!=0)
{
printf("no\n");
}
else
{
sort(sticks,sticks+n);//排序
l=sum/4;
if(dfs(0,0,0,0))
printf("yes\n");
else
printf("no\n");
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: