您的位置:首页 > 其它

POJ 1753 Flip Game

2016-06-27 17:23 267 查看
原题目网址: http://poj.org/problem?id=1753

题目:

Flip Game

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 39210 Accepted: 17050

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it’s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here “b” denotes pieces lying their black side up and “w” denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters “w” or “b” each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it’s impossible to achieve the goal, then write the word “Impossible” (without quotes).

Sample Input

bwwb

bbwb

bwwb

bwww

Sample Output

4

(图片好像复制不过来 = =)

题意:4*4一共16个格子,然后翻转,翻转一个,周围上下左右都要跟着翻转,如果存在一种情况,即翻转之后格子变成纯色,存在的话,输出最少翻转数,不存在的话输出“Impossible”。

思路:

对每一个格子进行枚举,反正数不大,每一种情况都考虑一下就好了。

啊,很直接的想法。

#include <cstdio>
#include <iostream>

using namespace std;

char rect[6][6];
int rectmap[6][6];
int step;
bool flag;

bool judge()
{
int k = rectmap[1][1];
for(int i = 1; i <= 4; i++)
{
for(int j = 1; j <= 4; j++)
{
if(rectmap[i][j] != k)
{
return false;
}
}
}
return true;
}

void flip(int row, int col)
{
rectmap[row][col] = !rectmap[row][col];
rectmap[row][col+1] = !rectmap[row][col+1];
rectmap[row][col-1] = !rectmap[row][col-1];
rectmap[row-1][col] = !rectmap[row-1][col];
rectmap[row+1][col] = !rectmap[row+1][col];
}

void dfs(int row,int col,int deep)
{
if(deep==step)
{
flag=judge();
return;
}

if(flag||row==5)
return;

flip(row,col);
if(col<4)
dfs(row,col+1,deep+1);
else
dfs(row+1,1,deep+1);

flip(row,col);
if(col<4)
dfs(row,col+1,deep);
else
dfs(row+1,1,deep);

return;
}

int main()
{
for(int i = 0; i < 4; i++)
{
cin >> rect[i];
}
for(int i = 0; i < 4; i++)
{
for(int j = 0; j < 4; j++)
{
if(rect[i][j] == 'b')
{
rectmap[i+1][j+1] = 0;
}
else{
rectmap[i+1][j+1] = 1;
}
}
}

for(step=0;step<=16;step++)
{
dfs(1,1,0);
if(flag)
break;
}

if(flag)
cout<<step<<endl;
else
cout<<"Impossible"<<endl;
return 0;

return 0;
}


暂时就只能用深度优先搜索写出这样的代码,其余的方法应该还有的吧。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj DFS 枚举