您的位置:首页 > 其它

【杭电-oj】-2055-An easy problem

2016-06-27 17:23 381 查看


An easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 20399    Accepted Submission(s): 13565


Problem Description

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).

 

Input

On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

 

Output

for each case, you should the result of y+f(x) on a line.

 

Sample Input

6
R 1
P 2
G 3
r 1
p 2
g 3

 

Sample Output

19
18
10
-17
-14
-4

 

Author

8600

 

开始输入一个数字,后来输入字符是注意用getchar()吸收换行符!!!多次输出也需要。

#include<cstdio>
#include<cstring>
int main()
{
int n;
scanf("%d",&n);
getchar();
while(n--)
{
char a;
int y;
scanf("%c %d",&a,&y);
if(a>='a'&&a<='z')
printf("%d\n",y-(a-'a'+1));
else
printf("%d\n",y+(a-'A'+1));
getchar();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: