您的位置:首页 > 其它

Acdream 1234 Two Cylinders(自适应辛普森积分法)

2016-06-26 19:11 309 查看
传送门

Two Cylinders

Special Judge Time Limit: 2000/1000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others)

Submit Statistic Next Problem

Problem Description

In this problem your task is very simple.
Consider two infinite cylinders in three-dimensional space, of radii R1 and R2 respectively, located in such a way that their axes intersect and are perpendicular.
Your task is to find the volume of their intersection.


Input

Input file contains two real numbers R1 and R2 (1 <= R1,R2 <= 100).


Output

Output the volume of the intersection of the cylinders. Your answer must be accurate up to 10-4.


Sample Input

1 1

Sample Output

5.3333

Source

Andrew Stankevich Contest 3

Manager

mathlover

题目大意:

给了两个圆柱的半径 r1,r2,他们的轴线垂直相交,让你求的是相交部分的体积。

解题思路:

这个题目首先我们对其积分:得到一个公式:

∫r0r12−x2−−−−−−−√∗r22−x2−−−−−−−√dy\int_0^r\sqrt{r1^2-x^2}*\sqrt{r2^2-x^2}dy

我们现在用正常的积分公式积不出来,我们就可以采用辛普森积分法进行积分,可以当作模板用

My Code:

/**
求两个交叉圆柱的体积
**/
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
const double eps = 1e-9;///精度
using namespace std;
double r1,r2;
double f(double x)///积分函数
{
return 8.0*(sqrt(r1*r1-x*x))*(sqrt(r2*r2-x*x));
}
double simpson(double x,double y)
{
return (y-x)*(f(x)+f(y)+4*f((x+y)/2))/6.0;
}
double jifen(double x,double y)///积分区间[x,y]
{
double ans = simpson(x,y);///二分区间积分减小误差
double mid = (x+y)/2.0;
double left = simpson(x,mid);
double right = simpson(mid,y);
if(fabs(ans-(left+right)) < eps)
return ans;
return jifen(x,mid)+jifen(mid,y);
}
int main()
{
while(~scanf("%lf%lf",&r1,&r2))
{
if(r1<r2) swap(r1,r2);
printf("%.6lf\n",jifen(0.0,r2));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: