您的位置:首页 > 其它

1032: A + B Problem II

2016-06-23 19:21 429 查看
1032: A + B Problem II

时间限制: 1 Sec  内存限制: 128 MB
提交: 99  解决: 18
[提交][状态][讨论版]
题目描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
输入

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces in the equation. Output a blank line between two adjacent test cases.
样例输入

4 1 2 112233445566778899 998877665544332211 998 2 4568 0012
样例输出

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110 Case 3: 998 + 2 = 1000 Case 4: 4568 + 0012 = 4580
提示

来源

.//同杭电大数  唯一注意前置0问题  该模板的优势体现出来了


#include<stdio.h>
#include<string.h>
char A[1001];
char B[1001];
void cal(int lenA,int lenB);
void add(char *a,int lena,char *b,int lenb);
int main(void)
{
//  freopen("D:\\test.txt","r",stdin);
int T;
while(scanf("%d",&T)!=EOF)
{
getchar();
for(int i=1;i<=T;i++)
{
if(i!=1) putchar('\n');
scanf("%s %s",A,B);
printf("Case %d:\n",i);
printf("%s + %s = ",A,B);
cal(strlen(A),strlen(B));
}
}
return 0;
}
void cal(int lenA,int lenB)
{
if(lenA<lenB) add(B,lenB,A,lenA);
else          add(A,lenA,B,lenB);
}
void add(char *a,int lena,char *b,int lenb)
{
int T=lena-1;
for(int i=lenb-1;i>=0;i--) a[T--]+=(b[i]-'0');//要记得是加上差值
int gap=0;
for(int i=lena;i>=0;i--)
{
a[i]+=gap;
if(a[i]>'9')
{
a[i]-=10;
gap=1;
}
else gap=0;
}

if(gap) printf("1%s\n",a);
else
{
int i;for(i=0;;i++) if(a[i]-'0') break; //去前置0
puts(a+i);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: