您的位置:首页 > 其它

poj2478【欧拉函数】

2016-06-23 18:38 288 查看
Language:
Default

Farey Sequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14596 Accepted: 5782
Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 

F2 = {1/2} 

F3 = {1/3, 1/2, 2/3} 

F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 

F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.
Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input
2
3
4
5
0

Sample Output
1
3
5
9

Source

POJ Contest,Author:Mathematica@ZSU
求前n个欧拉函数值的和

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
#include<list>
#include<vector>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=1000010;
long long num[maxn],eular[maxn];
void dabiao(){
for(int i=2;i<=1000000;++i){
if(eular[i]==0){
for(int j=i;j<=1000000;j+=i){
if(eular[j]==0){
eular[j]=j;
}
eular[j]=eular[j]/i*(i-1);
}
}
}
for(int i=2;i<=1000000;++i){
num[i]=num[i-1]+eular[i];
}
}
int main()
{
dabiao();
long long n;
while(scanf("%lld",&n),n){
printf("%lld\n",num
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj2478欧拉函数