您的位置:首页 > 大数据 > 人工智能

HDU 1532 Drainage Ditches (最大流)

2016-06-22 13:10 387 查看

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)


[align=left]Problem Description[/align]
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

[align=left]Input[/align]
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

[align=left]Output[/align]
For each case, output a single integer, the maximum rate at which water may emptied from the pond.

[align=left]Sample Input[/align]

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

[align=left]Sample Output[/align]

50

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<queue>
using namespace std;

//****************************************************
//最大流模板Edmonds_Karp算法
//初始化:g[][],start,end
//******************************************************
const int MAXN = 200+10;
const int INF = 0x3fffffff;
int g[MAXN][MAXN];//存边的容量,没有边的初始化为0
int path[MAXN],flow[MAXN],start,ed;
int n;//点的个数,编号0~n,n包括了源点和汇点

queue<int>q;
int bfs()
{
int i,t;
while(!q.empty()) q.pop();//清空队列
memset(path,-1,sizeof(path));//每次搜索前都把路径初始化成-1
path[start]=0;
flow[start]=INF;//源点可以有无穷的流流进
q.push(start);
while(!q.empty()){
t=q.front();
q.pop();
if(t==ed) break;
for(i=1;i<=n;i++){
if(i!=start&&path[i]==-1&&g[t][i]){
flow[i]=flow[t]<g[t][i]?flow[t]:g[t][i];
q.push(i);
path[i]=t;
}
}
}
if(path[ed]==-1) return -1;//即找不到汇点上去了。找不到增广路径了
return flow[ed];
}

int Edmonds_Karp()
{
int max_flow=0;
int step,now,pre;
while((step=bfs())!=-1){
max_flow+=step;
now=ed;
while(now!=start){
pre=path[now];
g[pre][now]-=step;
g[now][pre]+=step;
now=pre;
}
}
return max_flow;
}

int main()
{
int m;
while(scanf("%d%d",&m,&n)!=EOF){
start=1,ed=n;
memset(g,0,sizeof(g));
for(int i=1;i<=m;i++){
int u,v,w;
scanf("%d%d%d",&u,&v,&w);
g[u][v]+=w;
}
printf("%d\n",Edmonds_Karp());
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: